Wallet doesn't sync, have backup, lost priv key


#1

Hello. My btg core doesn’t sync. I have backup of my wallet, and it still doesn’t give me priv key (lost it) when i write “dumpprivkey”…
I had tried from another PCs but nothing happened. There’re not peers, network traffic(Have tried “addnode”). This has been happening since the fork. Before, i could enter easily.
I live in Kyrgizstan
Did i something wrong? Should i use Puplic Key Server which is on “Download Btg wallet” page?


#2

For the sync problem - are you sure you’re running version v0.15.1 and not version v0.15.0.1 or v0.15.0.2?

Only v0.15.1 will sync any blocks after the fork.

On wallet - if you have a backup of your wallet.dat file, don’t lose it. After installing v0.15.1, if you copy the wallet.dat into the folder, you should be able to access the wallet again.

I do not know why dumpprivkey is failing - make sure you’re copying the wallet.dat file into the correct folder; you may have more than one folder with the Core Wallet if your new install is not going into the same place as your prior install.

(I know that on my machine, at some point, I had installed v0.15.1, but when I rebooted, Windows would auto-startup the old v0.15.0.2 version, and I was confused for some time about why it was not syncing until I realized the old folder was still there and Windows kept auto-starting it.)


#3

Thanks for response.
Maybe I have same problem (auto-startup).
But:
As soon as i’d bought a new computer i installed btg wallet version 0.15.1. After i tried to use ElectrumG, but it can’t read my wallet.dat file.
And:
Yes I’m sure i am running 0.15.1 version.
I manually copied wallet.dat into the folder (instead of another “wallet.dat”).


#4

ElectrumG won’t work with wallet.dat; that’s only for the core wallet. (It’s a Berkeley DB database file.)

I suspect your sync problems and wallet.dat files are not related to each other, but I could be wrong.

If you fire up the wallet and go into Help, Debug Window, Peers Tab - do you see peers there? Are your peers running 0.15.1? Can you send a screenshot of that?


#5

Thanks, i’d got a privkey. But wallet still doesn’t sync.


#6

Ouh! Thanks! :smiley:
I deleted all btg folders and files, and used “addnode” command (german ips). And now wallet is syncing.
Thank you very much, it turned out that it was easy.
I’d got a privkey.


#7

Great!

If you adjust the columns on your peers, you can see what version they’re on:

If interested, you may be able to speed up your download if you manually kick off any “slow” peers, to have a chance of connecting to a new peer that’s faster - however, if you are already receiving blocks as fast as your internet will allow, you won’t gain anything by doing this.

Because you are re-loading the blockchain, you are many years behind and can pick up blocks from people running old nodes. It’s OK to leave them as a peer if they are close and are giving you a lot of data - the blocks they have are the same up until August 3. After you get to August 3 of 2018 (the latest update fork), your node will begin to automatically ban peers who are still using the old software because they’ll try to feed you an invalid block from August 3.

Old nodes will periodically re-connect with you, and your node will auto-ban them for 24 hours because their software is old. (People need to update their nodes!)


#8

Thank you very much! For info and for HELP.
:smile:
I’ll try to speed up.